Error: The Protector viewer window is blank or momentarily displays an image. No error message is displayed.

The problem is that you don’t have Adobe Flash player installed for Internet Explorer.¬†¬†Locklizard Protector Viewer works with libraries used by IE even if you are using a different default browser (i.e. Firefox).

You have to open your Internet Explorer browser, go to http://www.adobe.com, and install the latest Flash player.