Error message: mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication.

This error can be caused after installation of the LockLizard administration system. To resolve it you must use the “Flush Privileges” command on the SQL server.

Below is the complete error message:

“MySQL Error 2000: mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD(‘your_existing_password’). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file

This either means that the username and/or password information you typed are incorrect or we can’t contact the database server at nnn.nn.nn.nnn. This could mean your host’s database server is down.

Are you sure you have the correct username and password?
Are you sure that you have typed the correct hostname?
Are you sure that the database server is running?
If you’re unsure what these terms mean you should probably contact your host.”